Skip to main content
Nintex Community Menu Bar

Error when deploying from K2 Designer for SharePoint - The remote certificate is invalid according to the validation procedure

  • August 10, 2015
  • 0 replies
  • 30 views

Forum|alt.badge.img+10


 

Symptoms


While trying to deploy any process from the K2 Designer for SharePoint, we receive the error

System.Exception:
System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.

 

Diagnoses


This error indicates a certificate issue, however we received no certificate errors while accessing SharePoint from the client machine or from K2.

We ran a fiddler trace from the SharePoint WFE as the K2 Deployment Application Pool account, and were able to get an error indicating that there was a problem with the Thawte certificate. When we allowed Fiddler to proceed, ignoring the errors, the deployment succeeded (since Fiddler was being used as the proxy). When we disabled Fiddler, the problem came back.
 

Resolution

There was an intermediate URL (http://tj.symcb.com/tj.crt) that is valid for the certificate that was being blocked. The security group was able to unblock the URL and the issue has since been resolved.