Skip to main content
Nintex Community Menu Bar

Error trying to register new instances of Service Objects

  • April 10, 2015
  • 0 replies
  • 10 views

Forum|alt.badge.img+18


 

Symptoms


Error trying to register new instances of Service Objects
 

Diagnoses


Error trying to register new service instances of SQL or CRM via the BrokerManagement.exe:

SQL
- Object Reference not set to an instance of an object

CRM
- Unable to load one or more of the requested types.
 

Resolution

I believe the BrokerManagement.exe tool is a legacy tool that is primarily used only for configuring integration with Salesforce. Instead, please try using the "Smartobject Service Tester Tool" located in the "C:Program Files(x86)K2 blackpearlBin" directory.

Under the ServiceObject Explorer category, if you right click on the ServiceType that you want (CRM, SQL), a "Register ServiceInstance" option is available that will allow you create a new Service Instance for exposing the appropriate Service Objects.

Backends <-> Smartobject Server <-> Service Type/Broker (SQL,CRM,etc.) <-> Service Instance (SQLServer1, SQLServer2, CRMServer1, CRMServer2) <-> Service Object (SQLTable, SQLView, SQLStoredProcedures, CRM Entities, etc.) <-> Smartobject