Skip to main content
Nintex Community Menu Bar

Error running SQL SmartObject connected to a stored procedure

  • May 27, 2016
  • 0 replies
  • 12 views

Forum|alt.badge.img+10


 

Symptoms


When running a SQL SmartObject connected to a stored procedure, you receive the error "Unable to start a nested transaction for OLE DB provider "SQLNCLI10" for linked server "[SQL SERVER]".
A nested transaction was required because the XACT_ABORT option was set to OFF."
 

Diagnoses


This occurs when a transaction is nested and cannot roll back to become a distributed transaction.
 

Resolution

Add "SET XACT_ABORT ON" to the Stored Procedure that the SmartObject was based on, delete the SmartObject and recreate it with the same GUID.