Skip to main content
Nintex Community Menu Bar

Error issuing high trust token message while configuring K2 app after K2 upgrade to 4.6.10

  • August 12, 2015
  • 0 replies
  • 14 views

Forum|alt.badge.img+16


 

Symptoms


While running K2 for SharePoint App registration wizard, I encountered High trust error message. The issue is started after upgrading to Blackpearl version 4.6.10. This account is already a site collection admin on the site.

Error Message: Open Authorization. Error issuing high trust token.

I did find below link which talks about inconsistency trust control between SharePoint and K2 and how to fix it. Please let me know.

http://community.k2.com/t5/General/K2-for-SharePoint-App/td-p/74460
 

Diagnoses


When running K2 for SharePoint App registration wizard, the K2 app is trying to call SharePoint Integration Helper method SmartObject’s Manage OAuth token method, and this is where it throws the error message.

Fiddler trace shows the following AjaxCall.ashx pointing to SP Integration Helper SmartObject with guid (f343a8d0-c7c6-4ad1-b72d-07ed5b568c46).

 

Resolution

Switched the SharePoint Integration service’s authentication type to use Service Account, and added the K2 service account to the Site collection administrator. After that, the user was able to complete K2 for SharePoint 2013 registration wizard.