Skip to main content
Nintex Community Menu Bar

Error during registration wizard, step "SharePoint Service Broker":

  • August 5, 2016
  • 0 replies
  • 7 views

Forum|alt.badge.img+7


 

Symptoms


Error during registration wizard, step "SharePoint Service Broker":

VALIDATION The remote server returned an error: (403) Forbidden. Failed to initialize the Context: URL: http://Domain/Environment Username: Error Details: Method SharePointService.initializeContext x-ms-diagnostics: 30000000 reason = SSL is required SPRequestGuid: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

 

Diagnoses


The issue could appears if SharePoint is in HTTPS and K2 is in HTTP (or reverse).
 

Resolution

This issue was resolved by running the following Powershell script on the customers SharePoint server:

$stsc = Get-SPSecurityTokenServiceConfig
$stsc.AllowMetadataOverHttp = $true
$stsc.AllowOAuthOverHttp= $true
$stsc.Update()

This allows the ability to use OAuth over http.