Skip to main content
Nintex Community Menu Bar

Error Deploying K2 for SharePoint

  • May 6, 2016
  • 0 replies
  • 11 views

Forum|alt.badge.img+5

Symptoms

 


Error Deploying K2 for SharePoint 
 

 

 

Diagnoses

 

 

 

 

 

Unable to deploy K2 for SharePoint - Core Components.wsp with the following error message:

 

 

 

 

 

Some of the files failed to copy during deployment of the solution.

That can happen when deployment process unable to add the specified assembly to the global assembly cache:

 

 

 

 

 

ISAPISourceCode.SharePoint.Workflow.dll.
Error: Cannot add the specified assembly to the global assembly cache: ISAPISourceCode.SharePoint.Workflow.dll.

 

 

 

 

 

Resolution

This problem can be caused by a Local Security Policy on the WFE Server blocking the Removal of Assemblies from the GAC . You can try to disable it and attemp Deployment and Configuration after this. To do this perform the following steps:

 

 


- Open Local Security Policy MMC
- Goto Security Settings -> Local Policies -> Security Options
- Locate “User Account Control: Run all administrators in Admin Approval” and change the setting from Enabled to Disabled

 

 

- Reboot and now the assemblies can be deleted