Skip to main content
Nintex Community Menu Bar

Error connecting to K2Mng

  • August 22, 2007
  • 5 replies
  • 14 views

Forum|alt.badge.img+4

I have an application using the K2Mng, and the Login function intermittently fails. This requires an IIS reset on the SharePoint server before K2Mng will accept a Login request again. This sometimes occurs as often as every 5mins or so. The exception is uncatchable in the code, although on occaisions (not usually) a pop up box appears in VS when debugging that says "System.ExecutionEngineException".


 Any ideas of what is causing this and how it can be resolved? Thanks

5 replies

Forum|alt.badge.img+5
  • August 22, 2007
Are the users attempting to login using Mng via your IIS site K2 Administrators?

Forum|alt.badge.img+4
  • Author
  • August 22, 2007
Hi Mike, this system is in test so I am currently the only person using it. No idea if I am a K2 administrator or not, but since the problem is only intermittent I doubt this would be the cause.

Forum|alt.badge.img+5
  • August 22, 2007

Are you making sure to call the Logout method?  You'll want to make sure that you wrap your code around a try, catch, finally and always make sure your logging out. 


If your dilegent about logging out then we can look elsewhere.


-mike


Forum|alt.badge.img+4
  • Author
  • August 23, 2007

Its not a Logout issue, that was my first suspicion and everything has been double checked.


Forum|alt.badge.img+4
  • Author
  • September 4, 2007
Any further ideas on this? This system is now running on our live servers, and we are experiencing the same problem (though not as often). This is a major problem as we can't do IIS reset on the live system, though it does seem that it normally starts working again if you leave it a few hours.