Skip to main content
Nintex Community Menu Bar

Email notifications stop working after upgrade to 4.6.8

  • December 11, 2014
  • 0 replies
  • 4 views



 

Symptoms


After upgrading to 4.6.8, email notifications stop working. The error in the HostServer log is: Could not load file or assembly '[INSTALLDIR]Host ServerBinSourceCode.EventBus.EventAssemblies.dll' or one of its dependencies.
 

Diagnoses


There are incorrect mappings in the EventBus.EventPolicyMapping and EventBus.LogEventPolicyMapping tables.

The SourceCode.EventBus.Server.config file needs to be updated.
 

Resolution

1. Open [INSTALLDIR]K2 blackpearlHost Serverin and locate the SourceCode.EventBus.Server.config file

- Update the mailassembly node to point to [Blackpearl drive location]:Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.MessageBusRecorder.dll instead of '[INSTALLDIR]Host ServerBinSourceCode.EventBus.EventAssemblies.dll'

- Update the mailassemblytype node to point to SourceCode.EventBus.MessageBusRecorder.MessageBusMailer instead of SourceCode.EventBus.EventAssemblies.Mail

2. Execute the following scripts on the K2 Database:

UPDATE [EventBus].[EventPolicyMapping]
SET [asmFullName] = '[Drive letter:]Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.MessageBusRecorder.dll',
[asmTypeName] = 'SourceCode.EventBus.MessageBusRecorder.MessageBusMailer'
WHERE [asmFullName] = '[INSTALLDIR]Host ServerBinSourceCode.EventBus.EventAssemblies.dll'

UPDATE [EventBus].[LogEventPolicyMapping]
SET [asmFullName] = '[Drive letter:]Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.MessageBusRecorder.dll',
[asmTypeName] = 'SourceCode.EventBus.MessageBusRecorder.MessageBusMailer'
WHERE [asmFullName] = '[INSTALLDIR]Host ServerBinSourceCode.EventBus.EventAssemblies.dll'

3. Restart the K2 service