Skip to main content
Nintex Community Menu Bar

Dynamic SQL Stored Procedure Service Issue

  • December 2, 2008
  • 2 replies
  • 17 views

Forum|alt.badge.img+3

Hi,


We are using the K2 [blackpearl] Dynamic SQL Stored Procedure Service  to call a stored proc to update a status on a table.


The issue we have is that it always fail with the following error "Object reference not set to an instance of an object.".  But when we do a retry, it works fine.


Did anyone had this problem.


Thanks


Dominic 

2 replies

Forum|alt.badge.img+9
  • Nintex Partner
  • December 3, 2008

That's a generic error which indicates that some object failed to create.  It might be due to something specific with your environment.  Given that the source code is available, I would try to attach a debugger to your execution host (should be your K2HostServer) with the source and try to step through it.  The error should be thrown from the Execute method.


Forum|alt.badge.img+3
  • Author
  • Nintex Partner
  • December 11, 2008

Hi Jonny,


We found out why the error was raise. We were mapping one of my field to the activity destination instance - user - FQN which returns null when the events is executed. When we did a retry from the workspace, it returned the propper value.


 We tried with and without a destination user with the same results. For now, we will set it to a fix value.


 Thanks


Dominic