Skip to main content
Nintex Community Menu Bar

Deploying and configuring the K2 Tasklist webpart

  • September 26, 2007
  • 4 replies
  • 13 views

Forum|alt.badge.img+9

Hi All, 


 


I am posting this up in case anybody needs a concise list of steps in getting the MOSS K2 webpart to work.


 


Deploy the webpart package


1.       Open SharePoint Central Administration.


2.       Go to the Operations page and under Global Configuration click the Solution management link.


3.       Click 'k2worklistwebpart.wsp'.


4.       On the next page click the Deploy Solution button/link.


5.       Then click OK to deploy it to all content site, or select a web application and click OK.


 


Populate the webpart gallery


1.       Select Site Actions, Site Settings, Modify All Site Settings


2.       Select Galleries – Web Parts


3.       Select NEW


4.       Scroll to the bottom of the page, locate and select SourceCode.*.*, scroll back to the top of the page and click on the POPULATE GALLERY button.


5.       Once done, return to the main page or any other page that you want to insert the TaskList webpart


 

4 replies

Forum|alt.badge.img
  • October 30, 2007
That's great, but how do I get the web part installed.  I have downloaded the installation from the k2 site, and the install says it is successful, but I don't see the k2 wsp listed on my Solution Management page.  Any suggestions?

Forum|alt.badge.img+9
  • Author
  • Nintex Partner
  • November 26, 2007

Did you check to see if the K2 MOSS components are being installed during the installation and configuration step?  I would also review the installation and configuration logs for errors to see if anything failed.


 Also do you see the K2 related components on the MOSS site? e.g. the K2 Administration tab in MOSS central admin?


Forum|alt.badge.img
  • March 19, 2008

When I get to the Solution Properties page the 'Deploy Solution' button isn't there.

Deployment Status is 'Error' is this the cause of the problem or is the 'Error' that it isn't yet deployed?


Forum|alt.badge.img+9
  • Author
  • Nintex Partner
  • March 25, 2008
I would start by checking if the K2 MOSS components were installed correctly by reviewing the installation and configuration logs.  If this doesn't help, I would next review the SharePoint logs as well.  Usually this gives some clues if there was any issues during the installation.