Skip to main content
Nintex Community Menu Bar

Database error when migrating from 4.6.3 to 4.6.9

  • April 28, 2015
  • 0 replies
  • 1 view

Forum|alt.badge.img+4


 

Symptoms


While performing a 463 > 469 upgrade, the client ran into the following issue while the DBs were being configured.
SqlException.Number != -2, so not handling it as a timeout. SqlException.Number = 3726. Exception: Could not drop object 'HostServer.SecurityLabel' because it is referenced by a FOREIGN KEY constraint.
 

Diagnoses


I performed the same upgrade in my test environment, but did not see the same issue. There must be some other upgrade path of upgrade failure that lead to the constraint that could not be dropped.
 

Resolution

First we reverted back to 463. I wrote a script that showed me all the constraints on the "HostServer.SecurityLabel" table. Once I knew what the constraints were, I "manually" dropped the constraint using SSMS and then performed the upgrade and all was well.