Skip to main content
Nintex Community Menu Bar

Connection Error with InfoPath Integration

  • October 9, 2007
  • 8 replies
  • 10 views

Forum|alt.badge.img+6

I'm getting a connection error when running the InfoPath Integration wizard.  The error specifically states "No connection could be made because the target machine actively refused it."  I'm receiving this message when I click FINISH on the InfoPath Integration wizard.  I've checked to make sure the service is running.  I've also tested the connections from the wizard and all seem OK.  Any ideas?

8 replies

Forum|alt.badge.img+9
  • Nintex Partner
  • October 9, 2007

Have you tried enabling full logging and checking for errors?


http://k2underground.com/forums/permalink/8506/18569/ShowThread.aspx#18569


Forum|alt.badge.img+6
  • Author
  • October 9, 2007
I just enabled logging and tried again.  I got the connection refused error again on screen, but nothing in the log file.

Forum|alt.badge.img+3
  • October 10, 2007

Hello


I have managed to reproduce your error only when the K2 Server hasn't been running.  It appears you don't need the Host server to be running in order for the connection test to function.


What I would urge you to do is run the K2 Host server in Console mode (to verify the server is running) and then run through your Infopath Integration wizard.


 Let us know how you get on.


 Cheers


Robin


Forum|alt.badge.img+6
  • Author
  • October 10, 2007

OK, so I checked to make sure the K2 server was running...and odly it wasn't.  So I started the Service, it looked like it started, but when I refreshed the service it was off again.  So I restarted a few more times before it finally stayed on.  Now when running the Server in Console Mode i get an error that states:


 12460","2007-10-09 07:08:11","Error","System","2001","ServerStartError","SourceCode.Hosting.Server.Runtime.HostServerEngine.StartHostServer","2001 Error Starting Host Server: bind() Failed. Error code: 10048","system","IPAddress","ComputerName","12460","c80b3f08f0be4d9c915ede040c461818",""


The console then closes so I am unable to run any logging.


Forum|alt.badge.img+11
  • Nintex Employee
  • October 10, 2007

The 'bind()' failure occurs when more than one HostServer application is running on the same machine on the same port.  Make sure that Service is stopped before attempting to run in console mode.


HTH,


Ockert


Forum|alt.badge.img+6
  • Author
  • October 10, 2007

Ok, I understand the difference between the Service and Host Server now.


 So I stopped the Service and started the Console Host Server and re-ran the InfoPath Integration wizard but I'm still getting the "connection actively refused" error, but no errors on the console.


Forum|alt.badge.img+6
  • Author
  • October 12, 2007
I just updated Blackpearl to the newest hotfix but i'm still getting the connection errors.  Anyone have any ideas?

Forum|alt.badge.img+6
  • Author
  • October 15, 2007
So I figured out the error was being caused by the InfoPath form I was using.  I think it was because the form had been previously deployed within a different demo k2 environment.  I went ahead and deleted the K2 fields and all the connections from the form and re-ran the InfoPath Integration Wizard and all is well.