Skip to main content
Nintex Community Menu Bar

Client Event Notifications not sending emails

  • February 17, 2015
  • 0 replies
  • 17 views

Forum|alt.badge.img+5


 

Symptoms

 


Just as a quick note, this environment has experienced this problem before. The previous time we managed to resolve it by doing this: http://community.k2.com/t5/K2-blackpearl/Could-not-load-file-or-assembly-SourceCode-EventBus/td-p/62734. Now it's a completely different problem.

"304640572","2015-02-11 15:15:56","Error","EventBus","7008","Processing","EventQueueProcessing.ExecuteAssembly","7008 The following error occurred while executing policy for CustomEventInstanceID: 1609 : Unable to load type : 'SourceCode.EventBus.MessageBusRecorder.MessageBusMailer'.","anonymous","0.0.0.0","dojcdnoc-k2pil1:C:Program Files (x86)K2 blackpearlHost ServerBin","304640572","7ad6f25b0da94e41aabdceb9c0a28d23",""
"304640574","2015-02-11 15:15:56","Error","EventBus","7498","General","EventQueueProcessing.Process","7498 An error has occurred: System.Exception: Unable to load type : 'SourceCode.EventBus.MessageBusRecorder.MessageBusMailer'
at SourceCode.EventBus.Server.EventQueueProcessing.ExecuteAssembly(Int32 CustomEventInstanceID, Int32 CustomEventID, ResolvedPolicyMapping resolvedPolicyMapping, Boolean isConditional, Int32 eventTypeID)
at SourceCode.EventBus.Server.EventQueueProcessing.ProcessEvent(Int32 ID)","anonymous","0.0.0.0","dojcdnoc-k2pil1:C:Program Files (x86)K2 blackpearlHost ServerBin","304640574","d75fcd175d2d444ba62d3427a722e254",""
 

 

Diagnoses

 


Noticing that the client had run into this issue before and that it was happening again even though the config changes on the mentioned KB were already done.

I suspected that a previous version of the process is being used that has the old information(config) cached.

 

 

Resolution

Investigating the config file everything was fine.
C:Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.EventAssemblies.dll
And should be: C:Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.MessageBusRecorder.dll

and the following had already been done by the consultant onsite.
1.In SourceCode.EventBus.Server.config update mailassembly and mailassemblytype pointed to the wrong .dll

a. Update the mailassembly to point to [Drive letter:]Program Files (x86)K2 blackpearlHost ServerBinSourceCode.EventBus.MessageBusRecorder.dll instead of [INSTALLDIR]Host ServerBinSourceCode.EventBus.EventAssemblies.dll'

b. Update to point to SourceCode.EventBus.MessageBusRecorder.MessageBusMailer instead of SourceCode.EventBus.EventAssemblies.Mail

2.On the DB:
[Please contact K2 Technical Support for assistance in updating the DB directly.]

 


After updating the design template and redeploying the issue was resolved.