Skip to main content
Nintex Community Menu Bar

"Authentication with server failed" in the Service

  • October 24, 2006
  • 9 replies
  • 31 views

Forum|alt.badge.img+2
Hello,

I have a K2.net Server (with SP4) service that is running in administrator (It stayed in the running state before I gave it higher privileges).

When I use the K2.net 2003 service manager, I have this message : "Authentication with server failed". I tried to edit the registration properties (NTLM, specify an account, ...) but without success.

It runs on an Windows 2003 Server box member of an AD domain, with K2.net 2003 Studio. The active directory is on another box, with the SQL Server 2000.

Thanks in advance

9 replies

Forum|alt.badge.img+11
  • Nintex Employee
  • October 24, 2006
When you say - "running in administrator"...

Is it local machine administrator or domain administrator? You need to start the K2Server Service under a domain account - to be able to authenticate users against AD.

Regards,
Ockert

Forum|alt.badge.img+2
  • Author
  • October 25, 2006
icon-quote.gifOckert:
When you say - "running in administrator"...

Is it local machine administrator or domain administrator? You need to start the K2Server Service under a domain account - to be able to authenticate users against AD.

Regards,
Ockert


The service run with the domain administrator rights.

Forum|alt.badge.img+4
  • October 25, 2006
if you try to connect using Service Manager on the local machine that K2 server is running on do you have any joy?

i am having a similar problem

also, try running in Console mode to see if you can see any errors or enable the error logging in the new Logger.config file

i've got a support call in at the moment for this so i'll update you here if we get any results

Forum|alt.badge.img+2
  • Author
  • October 25, 2006
icon-quote.gifwez_p:
if you try to connect using Service Manager on the local machine that K2 server is running on do you have any joy?

i am having a similar problem

also, try running in Console mode to see if you can see any errors or enable the error logging in the new Logger.config file

i've got a support call in at the moment for this so i'll update you here if we get any results


The service manager is on the same machine that the K2 server.

The console give nothing. I've enabled the Event Viewer and File logging in the Logger.config but I see nothing interesting in the Event Viewer and no K2Server.log is created...

Forum|alt.badge.img+4
  • October 25, 2006
our error turned out to be due to the service account requiring local admin permissions to make use of the new performance monitoring functionality in SP4

i've seen the 'Authentication with server failed' error when Kerberos hasn't been setup correctly

when you run the K2 server in console mode, make sure you run it under the same identity that you're trying to run the service under. what output do you get?

Forum|alt.badge.img+2
  • Author
  • October 26, 2006
icon-quote.gifwez_p:
our error turned out to be due to the service account requiring local admin permissions to make use of the new performance monitoring functionality in SP4

i've seen the 'Authentication with server failed' error when Kerberos hasn't been setup correctly

when you run the K2 server in console mode, make sure you run it under the same identity that you're trying to run the service under. what output do you get?


I don't know how to do that...

How do I setup Kerberos correctly (any manual/guide) ? How do I run the K2 server console with the same identity I run the service under (any command ?) ?

Thanks in advance

Forum|alt.badge.img+11
  • Nintex Employee
  • October 26, 2006
For Kerberos setup, please refer to KB article #123.
http://kb.k2workflow.com/Articles/KB000123.aspx

To run K2.net Server in console mode...
Make sure the K2.net Server Service is stopped in the Services MMC
Navigate to K2Server.exe with Windows Explorer (normally in 'C:Program FilesK2.net 2003Bin')
Right-click K2Server.exe and select 'Run As...'
Select 'The following user' and provide the credentials of the user used to start the K2.net Server Service.

HTH,
Ockert

Forum|alt.badge.img+2
  • Author
  • October 26, 2006
icon-quote.gifOckert:
For Kerberos setup, please refer to KB article #123.
http://kb.k2workflow.com/Articles/KB000123.aspx

To run K2.net Server in console mode...
Make sure the K2.net Server Service is stopped in the Services MMC
Navigate to K2Server.exe with Windows Explorer (normally in 'C:Program FilesK2.net 2003Bin')
Right-click K2Server.exe and select 'Run As...'
Select 'The following user' and provide the credentials of the user used to start the K2.net Server Service.

HTH,
Ockert


Ok, I've followed the tutorial and made the delegation but I still have an "authentication failed" error.

However, it seems to work when I set to "anonymous" the connection settings in the registration properties of the server.

I'll use it like that and if I see other authentication problems I'll watch again the Kerberos settings...

Forum|alt.badge.img
  • November 2, 2006
Hi,

I had the same problem and manualy repaired K2Server.config solved it:
<DataSources>
<DataSource Path="LDAP://DC=MyDomain,DC=local" Type="ActiveDirectory" NetBiosName="MyDomain" />
</DataSources>

Check this, because sometimes during installation it isn't correctly set.

Regards,
kamilm