Skip to main content
Nintex Community Menu Bar

Ambient aborted transaction when opening the K2 Designer

  • September 7, 2016
  • 0 replies
  • 7 views

Forum|alt.badge.img+4


 

Symptoms

 


About once a day, the K2Server throws an error stating... - "SmartObject Server Exception: The transaction has aborted". - "Cannot open a connection where there is an ambient aborted transaction". We can see variations on the above errors in workspace, the designer and almost everywhere K2.
 

 

Diagnoses

 


After some testing, we found that there was a bug when you use "groups" to assign SmartObject rights in workspace. This caused the "Ambient aborted transaction".
 

 

Resolution

A code fix was provided to resolve the issue.