Update a Choice Column in a flow

  • 23 September 2022
  • 5 replies



I have a "choice" column in a workflow that only gets updating in a task. After the task is completed, I want to display the choice that was selected in the same column in the list view in SharePoint. I'm struggling to achieve this in Nintex Automate Cloud, it was very easy to do in O365 as I set the column to be connected to "same column" in the form settings.


I tried the following:

  • Create a form variable and then use the Update Item action
    • It doesn't allow me to select my form variable in the Update Item action for this column (I'm assuming it's because it's a choice column and not a text/string column)
  • Query the list where this column is "after" the Task is completed and then use the Update Item action
    • Same issue as above, won't allow me to select what I need from the Query results


Here is a screenshot of what I am trying to do via an Update Item action:



Any help or insight is greatly appreciated!




Best answer by brent_read 23 September 2022, 21:26

View original

5 replies

Badge +2

Hi @ckatz,


The reason this is occurring looks like its actually because you're using the Assign Tasks to Multiple Users action and trying to pass the variable out of the collection.


There's two solutions to this depending on how the action is set up.  If its set as a First Response Applies then you should be able to select the First Response object instead of the Task Responses Object in your variable selection.


If its a setup for any of the other options then you'd want to use collection operations to find the index for the user/users that rejected the task using the Check for Item in Collection.  Then use the Get Item from Collection with the index to get the value and pass it to the update item action.

Hello @brent_read 


The setting in the Task was set to All Assignees Must Respond. Even though it's a task for multiple users, it's really one user based on a group email. This is how the migration tool brought the task into the flow.


NOTE: I have another column from the same Task form that is a text column, it allows me to Update the Item as expected for this column using the Update Item action.


Based on your suggestion, I changed the Task setting to First Response and then tried to use the Update Item action....but same results, it's not allowing me to select any of the options even from the First Response path


Here's a screenshot


Badge +2

Hmmm, what happens if you create a new Choice control in the form and try to reference that control?  I just ran through a quick test migration of a workflow with a choice control in the form and I'm not seeing the same behavior.


If the new choice control works you may jest want to update it to utilize the same values and then remove the old control.  If not then I'd recommend reaching out to support so we can schedule a call to take a look at what's occurring.

Hi @brent_read 


aah...I know where the confusion is, the column I'm using is a Lookup column in SharePoint not choice. So when I configured the Task form I had to create a Data Source in order to get the column drop-down values to show in the form. 


Sorry about the mix-up, I've been looking at so many columns...I confused it with another column that is a choice column.


I still have the same open issue though, except it's for a column being populated by a Data Source/Lookup in the Task form. I want the selection made in the form to be displayed in the SharePoint list after the task is completed.

Badge +2

Sorry for the confusion.  Here's how to get this working.  The lookup column in Sharepoint expects an ID (integer) to be passed to it to set the value.  to get this using the data source in NWC you'd want to set the Data Lookup Control on your form to return the ID column as the value in the control.


That still gives you a text variable in NWC but you can use the Convert a Value action to cast the Data Lookup Text variable to an Integer type variable in the workflow.  Then plug the Integer type variable into the Update Item action to get this working.