cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Automation Master
Automation Master

Start workflow not starting (hanging)

Jump to solution

I have a workflow that has multiple start workflows inside (three to be precise).  all are configured to start and the main workflow is instructed to wait for their completion before continuing on.  I am having sporadic events where the main workflow is in progress and the child workflow is highlighted as starting the workflow as below:

StartWorkflowHanging.PNG

So sometimes, the main workflow completes and successfully starts and completes the three inner workflows (in fact it is 90% successful)

But sometimes, the main workflow will stick at "In Progress" and the workflow history will have one of the inner workflows highlighted as the current action (it could be any of the three, it doesn't seem to matter).

Have asked Farm admin to check timer service is up and running as ex

Labels: (2)
0 Kudos
Reply
4 Replies
fhunth
Nintex Newbie

Re: Start workflow not starting (hanging)

Jump to solution

In some cases an environment (which works) against another (where the error occurs). One server has "Enable safe looping" set to Yes, the other server has set to "No". Changing the "Enable safe looping" setting to "No" on the server, and the "Start Workflow" action with wait for completion checked, works.

Here are some related links:

Stalled Start Workflow action

Stalled Start Workflow action

Reply
Automation Master
Automation Master

Re: Start workflow not starting (hanging)

Jump to solution

Hi Fernando Hunth​ thanks for getting back to me - will look at those links now.

it is not two different environments, it's the same one where occasionally the issue happens.  it is not an options for us to disable safe looping as per our governance.

0 Kudos
Reply
Automation Master
Automation Master

Re: Start workflow not starting (hanging)

Jump to solution

Hi Cassy,

I've seen this action hang up when there was an issue with the Timer Service - resetting it seems to fix it in a lot of cases.   Maybe give it a try on your server(s) and see if helps any.

-Mike

0 Kudos
Reply
Ramprasad
Nintex Newbie

Re: Start workflow not starting (hanging)

Jump to solution

Hi Folks,

 

I am too facing the nintex workflow issues in sp 2013 onprem environment.I have done restarting the timer services.But still the workflows are in hanging in starting stage .they are not moving to Inprogress stage.Please help.

 

0 Kudos
Reply