cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Conditional Start on Modified - Not working

Hi everyone,

I have a workflow running on a choice column, and have set it to start on modified based on whether the column changes from its previous value. When I change the selection in the column, it does not fire.

To try to determine why that was, I changed to on modified condition "yes" then changed the the selection in the column and the workflow fired.

Any idea on why it would work for "yes" on a modified condition but not a "compare previous" condition?

If it matters; the workflow begins with a switch action.

Reply
33 Replies
Workflow Hero

Re: Conditional Start on Modified - Not working

Hello Howard,

I had a similar question to yours a while back.

Have a look at the following question and answers - How to fire a workflow only when an item is modified

This might help you

Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

Thank you, I have followed that post and will use it for future reference but I don't find it applicable to the issue I'm currently having.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

Hello guerlain.howard@amerigroup.com​ -

In your workflow settings, look at 'Start when items are modified', and set that to 'Conditional'.

In your conditions, you can evaluate previous values like so:

This will cause the workflow to trigger when the item is modified AND (more specifically) the status has changed.

Hope this helps!

Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

This is exactly how I had it set up. It does not work, the workflow will not start with that condition set.

It will however work when I only select "Yes" for it to run when modified.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

In your choice field that you are referencing, what are your options?

What about the display name and values?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

The choice default is "None."

The choice field is populated by a site workflow, and changes to "Pre-Assign 1"

The choices are:

None

Pre-Assign 1

Pre-Assign 2

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

Ah ok, missed the site workflow piece of it.

I tested it where the list choice column is updated by a site workflow and it did run the list workflow upon update.

There was a delay, only because the way timer jobs run, but it did fire eventually.

Can you confirm that list item is being updated properly and as expected?

I did see "starting" in the workflow column after the site wf updated the item:

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

Yes, the site workflow is updating the list properly. I have even tried manually changing choices as well.

The workflow that has the condition start does not even show as starting or anything for me

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional Start on Modified - Not working

Hmmm...Not sure without diving into what you have setup already, and to confirm, you are attempting to use a site workflow to update a list item, which then triggers a list workflow, correct?

I would create a new workflow on the same list and make sure that it is behaving as intended.

Set the "start on modified" conditionally and test it to make sure its working.

I have seen in the past strange behavior and had to start over from scratch and it cleared up issues.

0 Kudos
Accept as Solution Reply