Julie
Nintex Newbie

Nintex 2019 - Document Set - Copy to SharePoint - Decimals issue

Hi there,

 

I've got a NW2019 workflow that is copying a doc set from to another folder including all its metadata using "Copy to SharePoint" activity on a site with the regional settings set to French (Switzerland).

 

During copy activity, most of the metadata are properly copied but I have an issue with Decimals number field (let's call it Amount).

  • If the source doc set has an amount of 1'234,00 -> the new doc set has the same amount 1'234,00 => which is good 😄
  • If the source doc set has an decimal amount "1234,50" -> the new doc set has its value set to 1'2345,00 => which is wrong
  • If the source doc set has an decimal amount "1234,99" -> the new doc set has its value set to 123'499,00 => which is wrong

Depending of the digits number, my amount is multiplied by 10 or 100 during copy.

 

I tried to reuse the same workflow to copy not a document set but a document, and in this case the Amount field is copied properly.

  • If the source doc has an amount of 1'234,00 -> the new doc has the same amount 1'234,00 => which is good 😄
  • If the source doc has an decimal amount "1234,50" -> the new doc has its value set to 1'234,50 => which is good 😄
  • If the source doc has an decimal amount "1234,99" -> the new doc has its value set to 1'234,99 => which is good 😄

 

While browsing Nintex SP2019 release note, I found out that I may need to upgrade to the latest version (5.2.1.0) in order to get "Fixed mismatch metadata while copying document set to destination document library using Copy to SharePoint action (131869)".

 

I've upgraded my environment without any luck, I still have an issue with the decimals during the copy of a document set.

 

I guess that the issue is coming from the "Copy To SharePoint" activity by design, and that this activity is not fully compatible with French (Switzerland) regional settings.

 

Any advice on how to fix it ?

 

Thx.

 

0 Kudos
Reply