andreapasutti
Nintex Newbie

How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

I'm using the Request Data action and I have created a new content type and added only 1 field to it, "Repeat Code", and the value is stored in a variable. When the email notification goes out to the recipient, it includes text of the form at the bottom of the email (see attached). How do I make that go away? Switching to plain text didn't do it, so I switched back to Rich Text. My HTML text ends after my "dataOutputBody2_text" variable, so it isn't being thrown in there. I know what this is, it's the task form the recipient gets when they click on the link to respond to the task. Why is it showing up in my email notification?

Reply
6 Replies
cassymfreeman
Automation Master
Automation Master

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Can you show configuration of the request data action please?

0 Kudos
Reply
andreapasutti
Nintex Newbie

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Here you go.

Action 1.png

Action 2.png

0 Kudos
Reply
cassymfreeman
Automation Master
Automation Master

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Where do you define dataOutputBody2_text?

0 Kudos
Reply
andreapasutti
Nintex Newbie

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Earlier in the workflow, but I looked at that when I exported the verbose logging window. The content of the variable ends after the postal code and that's how it also appears in my HTML.

Variable from export:

Variable.png

HTML of Request Data action task notification:

Task Notification HTML.png

0 Kudos
Reply
jackgelo
Automation Master
Automation Master

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Hi,

I've seen a similar output when I have Lazy Approval enabled on the Request Data, from your screenshot it looks like Lazy Approval is not enabled on that environment, is it the same environment where you experience the issue?

In that case, that text part is there because with Lazy Approval you can fill the fields of a request daty simply by replying to the notification email and filling the brackets.

Giacomo

View solution in original post

Reply
andreapasutti
Nintex Newbie

Re: How do I keep the fields from the Content Type in my Request Data action from appearing in the email notification?

Jump to solution

Actually, Lazy Approval was enabled and that's exactly what it was. I ran a test and entered my repeat code in between the brackets and it worked. I think that is confusing because it's not very well formatted. It's not intuitive, you'd have to explain to the recipient that they would have to hit reply, then enter the data in between the brackets. I turned off Lazy Approval.

Reply