cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Email variable fails to store properly when searched by job title

Jump to solution

Hey Nintex Community,

 

Just had some complaints about failed instances. When I went to check on them, they all failed at the same point: a "Get user details" action which takes as input the email variable stored earlier in the workflow (using a "Query user" action) and produces as output the associated name (in this case, of our admin assistant).

 

When similar issues have occurred in the past, it was usually due to small changes in employee titles--I have the workflow set up to find email addresses based on job titles, so as to avoid issues with staff turnover. I checked the assistant's title, which had indeed changed by a few characters (a word was no longer abbreviated). I updated the title in the Query Users box. 

 

However, unlike in the past, this didn't fix the problem. I still got a "Bad Request: email is required" error at the point in the workflow when the email variable should have been used to look up the admin assistant's name.

 

I've temporarily fixed it by having the Query Users action look for our admin assistant's name instead of job title. This has the obvious problem of breaking as soon as a different person becomes our admin (not likely to happen in the short term, but I've tried to future-proof this workflow wherever possible). 

 

Any help is appreciated. Thanks in advance. 

Labels: (1)
0 Kudos
Reply
4 Replies
Highlighted
Community Manager Community Manager
Community Manager

Re: Email variable fails to store properly when searched by job title

Jump to solution

@jstraus in your workflow if you try logging the required email address to the instance history directly before the Get User Details action, does it return the right value? I'm curious to see what information is getting passed to the action.

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Email variable fails to store properly when searched by job title

Jump to solution

@butlerj Good idea. Looks like it stores nothing. Indicating either that my regular expression to snip the email from the Active Directory entry is broken (unlikely as it's identical to regex's I use elsewhere that are working fine), or it's specifically failing to find an email address associated with the title I gave (copied straight from Azure, I checked to make sure there were no extra spaces--every character is correct). 

0 Kudos
Reply
Highlighted
Community Manager Community Manager
Community Manager

Re: Email variable fails to store properly when searched by job title

Jump to solution

@jstraus does the title maybe have a special character in it that is getting interpreted incorrectly? Not 100% sure why it wouldn't be able to match off of a copy paste from AD other than potentially AD holding some "unseen" value that doesn't get translated correctly.

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Email variable fails to store properly when searched by job title

Jump to solution

 

@butlerj I solved it. The issue was a typo in Azure after all; apparently I didn't copy it into Nintex but just wrote it out by eye. The typo was so small that I totally glossed over it (Devopment instead of Development). Thanks for the help. 

 

View solution in original post

Reply