Sharpharp1
Apprentice

Loading a Form with a state hangs while loading intermittently

Hi,

 

Using a form with a couple of states which i reference in Workflow emails.

 

When the users click the URL (containing the link to the form state), half the time the form hangs indefinitely on the K2 loading spinner. If the user then hits F5 again on the same URL, it loads up fine.

 

Other times, the form loads first time

 

Anyone else have this issue and what on earth could be causing the hang

 

Currently collecting smartobject and trace logs, but just wanted to put the question out there for you fellow K2ers

 

Thanks

0 Kudos
3 Replies
MichaelS2
Apprentice

Re: Loading a Form with a state hangs while loading intermittently

Hello,


 


By chance is this only happening in one specific browser, or is the happening also in like Edge, Chrome & Firefox?


 


Thanks,


Michael

0 Kudos
Sharpharp1
Apprentice

Re: Loading a Form with a state hangs while loading intermittently

Tested in IE and Edge, very random but after server restart and adding Smartobject logging, seems to have stopped the form hanging for the last two days.

 

I'm not sure why, but i'm wondering if the Memory usage on the server could be a factor:

 

SQL Server Windows Nt - 64 bit - This is hovering around 2Gb memory usuage after 2 days of testing

IIS Worker Process - This is now 1.2GB memory usage

 

Overall server is using 47% memory, CPU is fine at around 5-10%

 

Any ideas?

 

0 Kudos
MichaelS2
Apprentice

Re: Loading a Form with a state hangs while loading intermittently

Hello,


 


Memory usage on a server most plays a big part. Do you have any scripts or SQL calls running? This could be a big factor on performance as well. Also, the uptime of the server, if it's always up and never gets a reset eventually the memory cache will fill up causing the machine to start load slower and slower overtime. Best practice would be to have a server reset scheduled every now and then clear the cache and refresh the system.

0 Kudos