AaronAcosta
Novice

401 - Unauthorized: Access is denied due to invalid credentials.

Jump to solution

Hi forum,

 

First, if you see this question duplicated please remove or merge it, because I can't see my post in the forum from some minutes now.

 

Ok, so, I'm performing an installation. K2 will be integrated with Sharepoint 365. I have installed K2 and the service is up. I can see and work in Designer and Workspace inside the server, no problem. I require that this services are available form internet, so people can work remotely. I have donfigured the DNS for the server and I can ping it without trouble, but when I try to access the Designer URL, i get a "401 - Unauthorized: Access is denied due to invalid credentials."

 

Am I missing some configuration in IIS or somewhere else?

 

Thanks in advance

 

PS. Later, I'll use the DNS to configure Sharepoint 365

Reply
3 Replies
BryanPeters
Apprentice

Re: 401 - Unauthorized: Access is denied due to invalid credentials.

Jump to solution

It sounds like it is most likely IIS. I am not sure what kind of authentication you might be using but I would start with opening IIS and checking your authenitcan settings. Also make sure your application pools are running. You could check the permissions of the service account and administrator account and make sure they have the correct access on the server. If those things look correct you might check the bindings and make sure they are configured correctly. The very last thing you could do is re-run the configuration manager for Blackpearl and check the application pools and the IIS Bindings. Are you using SSL? When you tried to access the site did you make sure the URL contained https? I know this is probably an obvious thing but sometimes it is easy to miss. I hope this helped. Please let me know if it did. Good luck!

 

Thanks,

Bryan Peters

Reply
AaronAcosta
Novice

Re: 401 - Unauthorized: Access is denied due to invalid credentials.

Jump to solution

Hi Bryan,

 

For the K2Smartforms>Designer authentication I have:

 

Anonymous Authentication - Disabled

ASP.NET Impersonation - Disabled

Forms Authentication - Disabled

Windows Authentication - Enabled

 

But it doesn't show anything.

 

for K2 Blackpearl>Workspace I have the same settings and I can see the page (it pops a bad certificate error, though).

 

All the pools are running. Blackpearl pool pipeline mode is set to Classic. Smartforms is Integrated. Both Admin and Service Accounts are local administrators.

I'll check the bindings right away. I don't have any SSL configured, the only certificate is the one that K2 Installs.

 

Thanks for the input

 

Thanks for your tips

0 Kudos
Reply
BryanPeters
Apprentice

Re: 401 - Unauthorized: Access is denied due to invalid credentials.

Jump to solution

It looks like you are using Windows Authentication. If this is the case try the following configuration for Designer.

 

Anonymous Authentication: Enabled

ASP.NET Impersonation: Disabled

Forms Authentication: Enabled

Windows Authentication: Disabled

 

To get rid of the certificate error simply add K2 to your trusted sites. Remember that everyone who accesses this from the internet will recieve this error and will have to do the same thing.

 

We did our installation on our own as well and ran into a host of issues. I will give this piece of advice. We made several changes to to IIS settings and even the config file to MAKE k2 work. (Including authentication setting) In the end we decided to reinstall k2 and make sure we were not configuring something incorrectly. We did this several times and eventually we figured it out and it worked without hacking anything. We felt like this was the best approach as opposed to making manual changes. What we found was we were not installing things in the correct order. Once we figured this out and did a complete re-install and slowly stepped through the configuration manager. Everything worked without making changes to the IIS settings after installation.

 

The order of installation was as follows:

 

K2 Blackpearl

K2 Smartforms

K2 Smartfoms Control Pack.

 

You might also think about creating a self signed certificate if you haven't already. 

 

You may have already found this but if not here is something that might help: http://help.k2.com/help#!/K2 blackpearl/4.6.11 

 

Please let me know if the authentication settings helped.

 

Thanks,

Bryan Peters

 

Reply