ConradMc
Cloud Wanderer

If server is rebooted, have to manually start K2 Service

Jump to solution

Hi,

 

Got an issue on our Dev Server regarding the K2 Server service.

 

I log onto the server (using our K2 service user account). I open Windows Services, I cannot Start the K2 Server:

ConradMc_0-1630656966723.png

 

I get this:

ConradMc_1-1630657013793.png

 

The only way I can get the K2 server up and running is to manually run the following file:

ConradMc_2-1630657092918.png

 

Which launches a console application in the background.

 

Problem with this workaround is that the server will stop if:

  • The server is restarted
  • If I disconnect the user from the server

(I have to log back onto the server and launch application again)

 

Is there some configuration I am missing? How can I ensure the K2 Server automatically runs correctly as a service, like the other K2 services?

 

 

 

Thanks

 

K2 5.3, Nov 2020 CU - Fix Pack 10

 

Labels: (1)
0 Kudos
Reply
3 Replies
tbyrne777
Workflow Veteran

Re: If server is rebooted, have to manually start K2 Service

Jump to solution
That is unfortunately how DEV licenses are set up - they will only work in Console mode. It should continue to run even if you disconnect though

View solution in original post

0 Kudos
Reply
ConradMc
Cloud Wanderer

Re: If server is rebooted, have to manually start K2 Service

Jump to solution

My mistake, it continues to run if I Disconnect. It stops running if I Sign Out. This makes sense now based on your feedback.

 

Never noticed this behaviour before. Thanks for your explanation.

0 Kudos
Reply
braddo
Forms Fledgling

Re: If server is rebooted, have to manually start K2 Service

Jump to solution

we had it running via the service until we installed a fix pack.  they had a bug in their system that allowed it to run as windows service, and then got fixed, reverting to only be run from the console window.

we are looking to get the console window opened when the service account logs into the server

0 Kudos
Reply