Bastien_T
Rookie

Don't see all my smartobject's fields in Workflow

Jump to solution

Hello community,

 

Starting here and there is something that I don't understand.

I'm working on a workflow started by a form. So I've a SmartObject (SQL) linked in the form that I can use in the workflow.

 

I have later added fields to my SO but I can't manage to get those later fields in my diagram. I only get the fields that were present when I intially associated my SO to my diagram through the form. Am I clear ?

 

Any Idea ?


k2capture1_3868.png
0 Kudos
Reply
4 Replies
Sunrise
Apprentice

Re: Don't see all my smartobject's fields in Workflow

Jump to solution

Hello Bastien_T


 


If you are talking about not having variables to map to, you must first add them in the context browser by clicking the “Add” link or option next to “VARIABLES”. You may user the following guides:


Fields: https://help.k2.com/onlinehelp/K2Cloud/UserGuide/Update_11/default.htm#K2-Workflow-Designer/Use/Cont...,


Set Variables step: https://help.k2.com/onlinehelp/K2Cloud/UserGuide/Update_11/default.htm#K2-Workflow-Designer/Use/Tool....


 


Best,


Sunrise

0 Kudos
Reply
HulisaniN
Apprentice

Re: Don't see all my smartobject's fields in Workflow

Jump to solution

Hi there  @Bastien_T 


 


I just did a bit of research of my own on this by doing a reproduction of what you did up there and i was able to solve this issue.


 


Below are the steps i followed to solve this issue after adding a field in the SO. 



  1. Delete the reference that already exists.

  2. Deploy the workfow

  3. When deployment is done drag the create reference  event

  4. Then configure the create reference event(choose the smartObject , then List method and identifier to be Id of the smartobject)

  5. then scroll down to output mappings and press the create 


After this steps I was able to achieve it.


Have a look at the screenShot for reference


 


Let me know is it helps


 


regards 


Huli


1_3869.png
2_3870.png
0 Kudos
Reply
Bastien_T
Rookie

Re: Don't see all my smartobject's fields in Workflow

Jump to solution

Hello Hulisanin,

 

Thank you for answering. I think I understood that was wrong.

Some of the fields were not in the SQL DB so I managed to create them in SO but the methods were not up to date and I had to remap in each methods. 

 

Thanks for having a look :)

 

0 Kudos
Reply
HulisaniN
Apprentice

Re: Don't see all my smartobject's fields in Workflow

Jump to solution

Hi  @Bastien_T 


 


Just to add 


 



  • You can also just add the extra fields in SQL DB,  

  • then in the management site, refresh your service instance

  • After that in your designer site you can then update you smartObjects.


I am not 100% sure but I think that you will have to still remap the references in the workflow


 


Regards


HulisaniN

0 Kudos
Reply