No ratings

Forms, Views, Workflows and SmartObjects not showing up in Sharepoint under K2 application area




Symptoms


Issue occurred after making changes to a list. The main change to the list included deleting the SmartObjects created by Appit when appifying a list. After deleting these objects the list asked to regenerate the objects since there weren't any associated. After recreating the objects all other items created for the list went missing on the artifacts page, but were visible in K2 Designer.

Diagnoses


The most likely cause is after making changes to the list, such as changing the name of the list, caused the objects created on the list to disappear as they no longer were associated with the originally named list.

Resolution

To fix this issue:

1. Open K2 Designer.
2. Find the objects that are "hidden" from the artifacts page of the list.
3. Create a new category folder, for example "Objects Repository".
4. Right click each item that is hidden from the list and use the Move To option to move these items to the newly created category folder.
5. Once the items have been moved, simply right click the objects and Move To the original category folder.

After making these changes the artifacts should again be visible in the artifacts page of the list in question.





Labels: (1)
Version history
Last update:
‎08-23-2021 05:15 PM
Updated by:
Contributors