cancel
Showing results for 
Search instead for 
Did you mean: 

Edit Task Forms on Office 365

alexjolynintex
Nintex Newbie
8 21 6,102

As you may all know, Nintex is closing the gap between features between O365 and On-premise versions of our products. Just a few important features are still missing. One of them (and maybe one of the most important one), is the Edit Task form feature for O365.  Guess what? That's exactly why I'm writing this blog!

Our july release is shipping this feature to O365!

I was really excited to test it, though I was having some worries about performances, but I have to admit that our development team has made a really well integrated feature that runs FAST!

Let me give you a tour of this new feature!

First of all, where will you find the feature? You will find this feature within the "Assign a task" action or "Start a task process" action.

WF edit.JPGOpen the task... and : button.JPG

Now you can see in the ribbon of the action a "Edit Task Form" button. Note that this button is greyed out for a few seconds (The form designer is loading in background). Once it has been loaded once, it opens in less than a second any other time!

When it's enabled, and you click on it, you will get the form designer opening as a frame on top of your workflow :

editform.JPG

You recognize this window, right? It's exactly the same you have on a list item form!

From this form, you can add :

  • General Form fields
  • Specific Sharepoint fields  (list lookup)
  • List columns : you can access any list column from the list on which you workflow is based;
  • Task columns : you can add on the form all the following task oriented fields :

taskcolumnsfields.JPG

  • The workflow variables : This one is quite important! It allows you to display any workflow variable from your underlying workflow!

Basically, if you know Nintex Forms already, you will find all the features you are used to seeing in NF365!

This is it!!

Enjoy playing with it!! Share the information, spread the word... it has a massive impact on how we use Forms within Workflow on O365!

For more information, see the product help: http://help.nintex.com/en-US/O365/Default.htm#cshid=3049.

21 Comments
robertwagenaar
Nintex Newbie

We're very excited about this new functionality and anxious to try it out right away.

Unfortunately, no success yet, this happened:

-  we created a completely new workflow

- we added an 'assign task' action (no other actions are in this test workflow)

- at first we could click 'edit task form' in the ribbon got message to update Nintex Forms (so far so good)

- we updated the Nintex Forms app (so far so good)

- now the 'edit task form' stays grayed out (even if we wait for minutes)

We tried with both 'Assign a task' and 'Start a task process'

We tested this with both IE10 and the latest version of Chrome (both on Windows 8.1)

Any suggestions?

Not applicable

Francis Bullet Sandico​  Ricardo Calingan​  Jason Blair Check out what's coming in their July release!  This will be great when we have another O365 client!

akrasheninnikov
Nintex Newbie

Just in case. Have you checked F12 console for error messages?

robertwagenaar
Nintex Newbie

I did just now: there is indeed an error: 'Permission denied' in hub.aspx on line 1, character 1

jonathankite
Nintex Newbie

Also not able to get this to load

Not applicable

Hi Robert Wagenaar​ and Jonathan Kite​, sorry to hear this isn't working for you, and thanks for letting us know. I'll follow up with the product team to see what's going on Will get back to you as soon as I can.

Not applicable

Has anyone been able to get this to work?  After updating my options to Edit Task Form are also greyed out

Not applicable

Hey Regis, we're currently looking into this. More to come.

Nintex Employee
Nintex Employee

Hi All,

Thanks for your patience. We identified an issue in the app when it's upgraded from the SharePoint app store that stops a file we need for the communication between the Workflow and Forms apps being updated. This file is critical in letting Workflow know Forms is installed and ready to be used.

We have submitted an update to the SharePoint app store to fix this issue and it will hopefully be approved in the next day or so. In the short term, there is a workaround. In the site you are building your workflow, remove the Nintex Forms app, clear your browser cache and then reinstall the Forms app. This will lay down the correct file in Office 365 and all will be good.

Sorry for the false start, Alex J had to mention how fast it was which has obviously brought Murphy out of hiding

Alex.

alexjolynintex
Nintex Newbie

Good job team & community!Getting this issue solved in a few hours is just something amazing!!

Not applicable

Will uninstalling the Nintex Forms App and reinstalling cause me to lose my currently working forms on the site? I'm assuming it would but just looking for clarification as I have several forms in use on my site.

Thanks,

Regis

jonathankite
Nintex Newbie

Wanted to confirm that removing and re-adding allows me to edit task forms now.  I was under the impression this would allow tasks to be edited via the mobile application under the "My Tasks" section.  Just a quick test list with a task action associated with it does not seem to cause that grayed out section to populate with a task I assigned to myself.  Am I missing something here?

alexjolynintex
Nintex Newbie

Hi Jonathan,

the "My task" section on the Nintex Mobile apps is not available on O365 at the moment. The edit task form feature doesn't bring this capability on the mobile App at the moment. It will come later on the product roadmap.

jonathankite
Nintex Newbie

Is there any guidance on how soon that will hit?  That seems like a fairly large feature gap.    

alexjolynintex
Nintex Newbie

If you are using Nintex Mobile for O365, yes it could be a feature gap for you. This feature will come, but the actual release date hasn't been communicated

kmcollins
Nintex Newbie

Hi,

This is great - particularly where I can show a pieces of information from the original form on the task form, however what I've found quite frustrating is that the 'body' field seems to be missing from the Forms Designer. Is there any reason this would happen?

ivan_yankulov
Nintex Newbie

Hello,

This is a great feature, especially the option to show fields from the related item.

However I run in issue, I had a customer with ~7 different task content types used in one workflow.

When I attempted to edit the forms I was unable to publish the workflow because I breached the limit for maximum number of arguments per activity (50). This is a limit on the number of variables that you are allow to have in a workflow and in SPO it is 50.

Please, can you give a official statement how many variables are added up when you edit the task forms from the workflow, like you have for the actions from the Store here : Workflow XAML failed validation due to the following errors: Activity 'DynamicActivity' has ## argum...

alexjolynintex
Nintex Newbie

Hi Ivan, you should redirect your question to the support, they will provide you a more accurate answer !

Not applicable

This post looks to be several months old at last edit, and I'm new to using Nintex Forms on 365, but I'm having exactly the same problem.  Design view on task forms hangs consistently, never get to work with it.

jtroup
Nintex Newbie

Same issue here. I tried in both browsers.

Not applicable

of course, then I talk with Anthony Montoya at Nintex Support, and he points out there are two ways to get to the Task Form design screen.  If you instead choose "Configure" on the task, there's an "Edit Task Form" choice in the ribbon - and THAT one works!  It takes you to a form that you can only Save (you don't Publish these) and when you Save and Close, you're back in the Configure dialog.  You need to save there, and then Publish workflow for your form change to take effect (remember, it's all contained in the workflow definition.)