Wrong Workflow Runs

  • 17 October 2019
  • 6 replies

Badge +3

There are two SharePoint 2013 lists, each with a Nintex form. Let's call them forms A and B, each attached to a workflow. Form A was connected to workflow A; and Form B was connected to workflow B. Everything ran fine.

Then I must have done something, I don't know, but now a new list item for form-A runs workflow-B. In otherwords, I create a new item in list-A with form-A, but workflow-B gets triggered. It's been like this for a couple of weeks.

Any ideas?

6 replies

Userlevel 5
Badge +20
Are you saying that when you add an item to a list that a workflow that is on another list runs?
What item does it run on?
This doesnt sound right.
Badge +3

re: "Are you saying that when you add an item to a list that a workflow that is on another list runs?"

Yes, exactly. When I add an item to one list, the workflow for the other list runs. The other list is empty, so I know that I haven't added an item to the wrong list.

The reason I think that the workflow to another list runs is because when I look at the workflow histories, it is the workflow history on the other list that shows activity. Also, the emails sent out have the behavior of the workflow attached to the empty list.

So, the item created shows up on one list, but the workflow runs for a different list.


re: "What item does it run on?"

It runs on the creation of an item.


re: "This doesnt sound right."

Yeah, it's bizarre. I don't know what I did to it; but it was working okay at one time until I started messing with it.

Userlevel 5
Badge +20
What did you do when you were messing with it?
Badge +3

I have since come to find out that a coworker was working on the site at the time that the workflows went awry. The last time it worked correctly was 10/8 and he made some changes to the site on 10/9. I've contacted him to find out what he might have done but I haven't heard back. I don't think he remembers. I don't know of anything that can be done in SP 2013 to cause such a change. I'll try to contact him again.

Badge +4

Don't you hate it when you find the exact issue you are having but when you open the post there are no solutions? I like solutions, don't you? I ran into this exact issue but found no solutions here even though this is a very old post. I did find out how to solve it. So I would like to share. 


I can reproduce this issue two ways. 

1. On a list with a Nintex Form and a Nintex Workflow I create a list template. Then I recreate the list some where else in SharePoint using the list template.

2. I use Content Matrix to copy the list to another site somewhere else in SharePoint. 


The Nintex Form always transfers very nicely with the list. All you have to do on the new list is edit the Nintex Form and then publish it and you are all set. But the Nintex workflow is an entirely different story. When you click on Workflow Settings Manage Workflows with Nintex Workflows you get no workflows listed. But when you create an item in the new list it somehow magically runs the workflow on the original list. 


So what is happening is that it is copying the reference to the workflow along with the list. When you create a record it is running that reference to the original workflow. You just need to delete the reference. How? Go to Workflow Settings and click on Workflow Settings...the first item on the drop down menu. You will see that it has a reference to the original workflow. Just click on "Remove, Block or Restore a Workflow". Then you can select "Remove" beside the workflow and OK to delete the reference. 




Thank you so much. This is the solution that i'm looking for. It works for me.