Workflow not send notification with multi approvers

  • 27 September 2022
  • 4 replies
  • 2 views

Hi. 
I have a workflow with Assign Flexi task, I have multiple approvers. If I send the task to one person I get the notification that the task has been answered, but if I send the task to more than one person I don't get the notification that it was answered. (if the answer appears in the system). I've tried to add the run-if operation, but I haven't been able to get the notification. I don't know if I'm giving the instruction wrong.
Can someone help me correct this part? How can I achieve my goal?



 




4 replies

Userlevel 5
Badge +10

Please add a screenshot of the Flexi Task configuration so we can see if this issue is related to the action configuration. Is the task being assigned to an internal group or to internal users?



I don't know if you're referring to this screenshot.

@bamaeric  I have tried different operations but still no success. I do not know what I'm doing wrong. The problem is if I assign more than one person in charge, it does not send me the individual notification that it was answered.



I show you my workflow. The only thing I want is that when there are several responsible parties, they send me the individual notification (To know who is the one who rejects it).



When they approve I don't want it to send me a notification, but if I want it to send me the last notification that everyone answered, I don't have any problems here. Everything's fine.



 





 

Userlevel 5
Badge +10

How many approvers are the group? In the Flexi Task configuration, you have the Behavior configured as "Majority must choose a specific outcome". This might be what is causing the unexpected behavior. Here's information about that configuration: Assign Flexi task 



 



I suggest adding a "Log in history list" action to both task branches. This will help you troubleshoot and make sure the workflow actually travels down the Reject path when the task is rejected.

Reply