Solved

Workflow does not show calculated column for new item

  • 13 October 2020
  • 4 replies
  • 18 views

I have a Nintex workflow for a SharePoint 2013 list. The list has a "Due Date" date column and an "FY" calculated column. FY calculates the Fiscal Year from Due Date. When I run the workflow on an existing item, FY is present and the workflow works as designed. But when I run the workflow automatically on a new item, FY has not been set, and the code fails.

Is this typical behavior? Would it be best to pause the workflow until FY has been populated before proceeding? Since the workflow fires after the save, I'm not sure why the calculated column is not already populated.

icon

Best answer by Michel 13 October 2020, 17:19

View original

4 replies

It can happen that the calculated value is not present as soon as the workflow starts, as you already suggests. You could add a pause/wait to the workflow, but you could also calculate the FY within the workflow. Would that work in your situation?

I ended up doing a pause. I originally thought of calculating FY in the workflow, but it was easier to do it as a calculated column.

I have learned that every action that writes to a List should be followed by a 'Commit Pending Changes' action. I seem to no longer need pauses if I do this.

Hi @Michel , I have a somewhat similar situation.  I have a calculated column for a DueDate.  It is conditional, so sometimes takes a DateEntered +2 or sometimes +4 (based on another calculated column).  Bottom line, this populates the DueDate always upon the initial entry, so this field exists and would be available to the workflow yet the Workflow still does not read/show this column.  



Is this still a case where you'd recalculate this on the fly inside the workflow?  I would certainly prefer to use the DueDate I already have set up with the proper logic.  I also found it difficult to see how I would do more than one condition for the calculation since I have two calculated columns in the source.  

Reply