how to execute action as admin

  • 21 July 2017
  • 5 replies

Badge +5

I have a workflow where users submit a request for a new price on a part.  Once the form is filled out, it goes to a Price List Admin group for approval.  If the request is approved, the Price list is updated with the new price.


We are running into a problem in that the workflow is failing when it tries to create a new item in the price list.  The only people who have the ability to create or edit the price list are the price list admins.  Anyone can make a request, but only the admins can approve the request and modify the price list.


It appears that the workflow is attempting to create the new price in the price list under the credentials of the initiator.  Since the initiator does not have permissions to create a list item, or edit a list item in the price list, the workflow errors out.


I seem to remember that there used to be a way to run an action with elevated privileges but I can't find it.  Google searching doesn't help.  This seems like a very common use-case.  It should be obvious but I can't find it.



Dave Petersen


Best answer by bamaeric 22 July 2017, 01:05

View original

5 replies

Userlevel 5
Badge +11

Hi David,

Which version of Nintex Workflow are you using?

For Nintex Workflow 2013, try using the Action Set action and placing the actions in it.  When you configure the Action Set, go to the Common tab and check the "Run as workflow owner" option.  Checking this option will cause this action, and any child actions, to run using the credentials of the user who published the workflow instead of the user who started the workflow.

For Nintex Workflow for Office 365, Nintex recently added the Action Set with an "Elevate permissions" option.  This allows you to run child actions in the Action Set with elevated app permissions. One thing to keep in mind is that the "Workflows can use app permissions" SharePoint site feature must be activated on your site to use the Action Set in Office 365.

Badge +5

Thanks!  I knew there was something like that somewhere - just didn't know where to look.  I appreciate it.  Big time saver.

Badge +3

Hi Eric,

Is this solution for both on premise and office 365 ? Because I am not able to see the option 'Run as workflow owner' in the Action set in on premise. I have enabled the app permission in manage site features as well.



If anybody looking for O365 based Nintex workflows to run with elevated privilege then use the "Action Set" action and check the option for "Elevated Permissions" will make the job done.



Try to  use the Help menu from SPO designer Ribbon.


Caution: The App Step action has been incorporated into the Action Set action. Existing instances of App Step in workflows now appear as an Action set. For more information, see Action Set.


Hope you are aware of activating the site feature for "Workflows can use app permissions" before achieving this functionality. In case of a failure, you may try to deactivate and activate this feature again to make it functional.



Kapiljith Rajappan

Unable to find this option in NIntex Workflow 2019. I have activated "Workflows can use app permissions". Able to see only the option 'Run as workflow owner' in the Action set (on-premise). But I don't want the workflow to be get executed with Owners access. Any help?