NWC Xtension gets error response: Not allowed to execute the request for non permitted hosts.

  • 18 January 2023
  • 2 replies

Badge +1

Hi Community,

I am building a workflow that calls an external API using a custom Xtension.

While the API calls sent through Postman work as expected, the same calls through Nintex Workflow are met with the error:

Received an error response from the connector: Not allowed to execute the request for non permitted hosts.. [Error Code: IO.XtensionExecute.ErrorResponse]

Alternatively, I have tried using “Call a web service” action using the same API call. It also fails to get a response.


2 replies

Userlevel 3
Badge +10

“Non permitted hosts” makes it sound like the API your trying to call has some kind of whitelist or authentication process that needs to happen in advance of your calls. Any chance the API you’re trying to connect to needs to know the calls are going to be coming from Nintex instead of Postman? I feel like I’ve seen that kind of thing before - where when I generate the app’s key/secret, it required the ip/host that was going to be utilizing those credentials. If I tried to use the credentials from any source other that what I specified, it wouldn’t work. 

Badge +1

@bsikes As far as I can tell, it doesn’t require the source. It does require authentication which is integrated into the Xtension.

When using web service calls, I have also tried to get auth token before sending the POST request, and the authenticaion is successfully received. This would indicate the target API acknowledges the auth request, not shoot it down. 

I also have a support ticket in progress for this issue. I will update here if I find useful information.