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Issue

Users experience the following error:

 

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This error can be seen during the following activities:

  • When workflow tries to send email
  • When form or workflow tries to fetch records from SharePoint Online
  • When form or workflow tries to fetch records from Azure Active Directory
  • Or any operation that involve using OAuth

 

This error may be thrown intermittently, or it can happen all the time when performing any of the activities above.

 

Diagnosis

The following errors can be see in HostServer logs:

 

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Look out for any error entries that were recorded around the the same time the transport connection error was recorded. If an error related to the path "/api/v2/environments/<guid>/resources" was seen in the logs at the same time, this means the K2 Configuration Service on one or all of your server nodes is down.

 

Resolution

  1. When you encounter this error, log a support case with Nintex Support. Include the error message, where users faced the error and this article in the support case.
  2. Nintex Support should be able to assist you in checking if your K2 Configuration Service is down, and assist you with restarting the service.
  3. A fix (Cloud Update 18 Fix Pack 5) has been released to prevent the K2 Configuration Service from stopping when a similar issue happen again. If you wish to apply the fix to your K2 Cloud environment, please inform Nintex Support.

 

Additional Information

You can refer to this document for the release notes of Cloud Update 18 Fix Pack 5. The release note contain a short explanation of what caused this issue to occur.

 

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