Solved

Getting "SmartObject property is required Property" error but method still runs

  • 1 December 2022
  • 4 replies
  • 29 views

Hi



I am getting the following error:



"SmartObject property SubcontractorID is a required property for selected method Create. Value must be set."



Yet after clicking "OK" the method has successfully run and the SubcontractorID property has been entered into its needed field.



Does anyone know why I am getting the error window despite the method running without issue?





The rule running this method is:



On View when Button is Clicked



Then on View execute Create method for all items that have been Added





This system is currently on K25, but was originally updated from K2 blackpearl.

icon

Best answer by MReed 2 December 2022, 00:31

View original

4 replies

Badge +12
It may be finding a blank row at the end of the list that it is considered "Added" - you should do a condition before calling Create to make sure the current context actually has a SubcontractorID to avoid the error

Hi,





I put in an advanced if for it the Subcontractor ID is blank or 0 not to run, and it still ran and gave the same error, but it also still created the new entry with the correct SubcontractorID entered.



Also I have tried it as a direct entry from the other table it is pulling the ID from, as a parameter and as a control. When asking a message to run before it runs the method it correctly pulls the information from all three of these sources.





So the error message seems to be occuring for no reason and I need to know how to make it go away otherwise the users will question it.

Badge +12
If you put a message right before the Create that includes the SubcontractorID value, what does it display and does the message appear for more rows than were actually added? This is very strange behavior indeed. One other thing to try is just execute the Create method on its own outside of a loop with some hardcoded values and see if you experience an error there as well. Trying to prove if the loop is the issue or the SmartObject itself.

The message that appears before the create method does show the SubcontractorID value.



The message only shows once even if multiple lines are added.



All rows that are being added would have the same SubcontractorID value.



When hard coded into the "On items added" method it still comes up with the error



Found that it had created an auto add on the view I hadn't spotted that was trying to run the same method without accessing a copy of the property.





Thanks for the help

Reply