K2 Management and Workspace unable to load

  • 16 February 2021
  • 0 replies
  • 225 views

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Issue

K2 Management and Workspace loading a blank page, and no one can access Management and Workspace.

 

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Diagnosis

  • Disabling bundling in Runtime web.config does not resolve the issue
     
    <add key="UseBundledFiles" value="false" /><add key="Forms.PostRenderCombining.Enabled" value="false" />
  • Designer does not seem to be affected
  • Capturing a network trace of the issue reveals that all resources that the browser attempt to load seem to result in a HTTP 302 redirect to K2 Workspace, which in turn, returns another HTTP 302 that redirects to Workspace again and so on. This results in a sort of loop, and nothing gets loaded.

 

Resolution

By default, your K2 site has a redirect enabled to route all request for the root site or invalid pages to K2 Workspace. For this scenario, there is something wrong with the HTTP Redirect on IIS that causes it to redirect everything to K2 Workspace.

 

To resolve this, you can go to IIS Manager, select your K2 site, select HTTP Redirect, and uncheck on "Redirect requests to this destination", and click on Apply. After that, perform a IISRESET, then check if your K2 Management and Workspace loads properly.

 

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