No ratings

Error executing Exchange Administration SmartObjects after 13 April 2021 Exchange security patch

Introduction

Microsoft recently released security update for Microsoft Exchange Server 2019, 2016, and 2013: April 13, 2021 (KB5001779) 
https://support.microsoft.com/en-us/topic/description-of-the-security-update-for-microsoft-exchange-... 
which changed the commands required to interact with Exchange.    

After applying KB5001779, the Exchange Management or Metadata SmartObjects (used by the Exchange Event Wizards when enabling or disabling mailboxes in a process or retrieving available Exchange servers or mailbox databases) will fail with error:  

An error occurred in the Exchange Administration Service Instance...The syntax is not supported by this runspace. This can occur if the runspace is in no-language mode. 

Cause 

This is a Known Issue from Microsoft: 

https://techcommunity.microsoft.com/t5/exchange-team-blog/released-april-2021-exchange-server-securi...  

Due to security changes in running PowerShell scripts to connect to the Exchange Server, our integration no longer functions. This was a completely unexpected change to a supported API. We are working to resolve the issue and will release fix packs for all supported K2 versions so that your solutions will continue to work with Exchange. 

Impact 

If you are running K2 blackpearl or K2 Five connecting to Microsoft Exchange Server 2019, 2016, or 2013 and use the Exchange Management or Metadata SmartObjects to enable or disable mailboxes, you will need to apply the fix pack once it is available. This KB will be updated with further information when available.

 

Labels: (2)
Version history
Last update:
‎05-20-2021 12:59 AM
Updated by:
Contributors