cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

I'm running a procdump on my Web Front End and I see this coming up alot...like 20 times a second I've also seen errors in my ULS related to Nintex Live.

We did not elect to install this feature on our farm when we installed Nintex.  Is this a bug thats already been reported or is there something we have turned on thats causing this to happen?

Thanks!

Tags (1)
0 Kudos
Reply
10 Replies
Highlighted
Nintex Newbie

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

Also in our Event Viewer we see eventid 7043 showing up randomly at all hours of the day or night and the user is IUSR so perhaps it is tied to something in a workflow?

Log Name:      Application

Source:        Microsoft-SharePoint Products-SharePoint Foundation

Date:          7/25/2016 3:00:02 AM

Event ID:      7043

Task Category: Web Controls

Level:         Error

Keywords:     

User:          NT AUTHORITY\IUSR

Computer:      removed

Description:

Load control template file /_controltemplates/15/NWLOnlineComponents.ascx failed: The expression prefix 'NWLResources' was not recognized.  Please correct the prefix or register the prefix in the <expressionBuilders> section of configuration.

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

  <System>

    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" />

    <EventID>7043</EventID>

    <Version>15</Version>

    <Level>2</Level>

    <Task>15</Task>

    <Opcode>0</Opcode>

    <Keywords>0x4000000000000000</Keywords>

    <TimeCreated SystemTime="2016-07-25T08:00:02.887114000Z" />

    <EventRecordID>133350</EventRecordID>

    <Correlation ActivityID="{E133939D-8B92-F020-63C9-8B6B4E8FD93A}" />

    <Execution ProcessID="5152" ThreadID="4600" />

    <Channel>Application</Channel>

    <Computer>removed</Computer>

    <Security UserID="removed" />

  </System>

  <EventData>

    <Data Name="string0">Load control template file /_controltemplates/15/NWLOnlineComponents.ascx failed: The expression prefix 'NWLResources' was not recognized.  Please correct the prefix or register the prefix in the &lt;expressionBuilders&gt; section of configuration.</Data>

  </EventData>

</Event>

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

Hi Richard,

can you reinstall Nintex on your WFE?

Or you can first try what the description says: "register the prefix in the <expressionBuilders> section of configuration"

If I understand this correctly, something is missing in your web config file, which is probably being set during installation.

Regards

Philipp

View solution in original post

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

Can you post a valid entry for this?

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

This is the entry in my web.config for the NWLResources prefix (SP 2013 on Prem):

This entry was created automatically by Nintex, most likely during installation process.

Hope it helps.

Regards

Philipp

Reply
Highlighted
Nintex Newbie

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

We left the checkbox to install Nintex Live unchecked so I can see why that line might not have been written to our web.configs. I've added it and the farm didn't crash so I'll monitor and post back later today. Thanks for taking the time to post that for me!

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

Richard Ruth schrieb:

I've added it and the farm didn't crash so I'll monitor and post back later today.

Be sure to always create a backup before editing the web.config manually as this is a very critical file.

Looking forward to hearing from you

Regards

Philipp

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

It looks like that has done the trick. Thank  you!

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

Great! Glad i could help =)

Regards

Philipp

Reply
Highlighted
Nintex Newbie

Re: E0434F4D.System.InvalidOperationException ("This feature requires Nintex Live and External Start. Please go to Live settings and click Enable to complete the installation.")

Jump to solution

I may have spoke too soon. I'm not seeing the original error in my Event Viewer but I now get:

Load control template file /_controltemplates/15/NWLOnlineComponents.ascx failed: The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047) (C:\inetpub\wwwroot\wss\VirtualDirectories\443\web.config line 591)

I imagine this is because it is not installed on my farm, nor do I want it installed. Nintex should not be looking for these files if the user did not install them.

The ULS logs

Failed to open the file 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Resources\NWLRes.en-US.resx'.

Failed to read resource file "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Resources\NWLRes.en-US.resx" from feature id "(null)".

I can see there is a NWLRes.resx and a NWLResource.en-US.resx but no NWLRes.en-US.resx file

I'd be interested to know if other users elected to no install Nintex LIve and are experiencing these issues. We are expeiriencing this issue in both QA and Production.

Reply