jbhuddleston
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution
Well we appear to have two related issues.
- the top row is being displayed.
- all the rows visibility are set to hidden. (My modification of your code addressed this).

All that is left is to make the top row go away, which your code should have done but did not. I think we are really close and there is some small thing left to do to fix this.
0 Kudos
Reply
jbhuddleston
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution
Got it!
In the Custom CSS section, I added
.nf-repeater-row-hidden {
display: none;
}
and that removed the top row.

Thank you for getting me here and for your patience.
I will mark the earlier post as a solution.
0 Kudos
Reply
MegaJerk
Collaborator

Re: Repeating section field area is blank after submitting

Jump to solution

I believe the reason why the initial solution I posted didn't work is because that entire fundamental hidden row isn't being generated correctly, and because all subsequent rows are generated from it, it affects their control visibility as well.

 

It's good to see that you found a workaround for your problem. 

 

I'd be curious to know if this issue is persistent across your entire installation or just the particular form you're working on. The only way I could think to test it would be to make a Test List, start a new Classic Form, add a Repeating Section and a dummy Single Line Text, and just see what it looks like in the Preview. if it works correctly, then perhaps this is something limited to the troublesome form in question, however if it persists and is displaying incorrectly, perhaps it's something that could be corrected with a Nintex update or by taking it to Nintex directly (with a trouble ticket). 

 

No matter, at least it's working now! 

 

 

0 Kudos
Reply
jbhuddleston
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution
It looks fine in View mode now but adding a new row in edit mode works for the single row of input boxes but not the people picker, date and textbox combination. The textbox is too large and overlaps the other two.
No matter, I think we are closing in on what is probably a deployment-specific problem.
I will test the same on simpler forms as you suggest.
Thanks again. Cheers.
0 Kudos
Reply
gaelyvin999
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution

good day, can you post the final solution, cause mine is doing the same thing and it's not visible unless i change the «hidden» to visible in the dev tools.

 

 

0 Kudos
Reply
jbhuddleston
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution
Custom Javascript
// this javascript makes every row in a repeating section visible (including the properly hidden one with the repeating context which shows up as blank space in my version)
NWF.FormFiller.Events.RegisterBeforeReady(function () { NWF$(".nf-repeater-row").each(function(index, repeatingSection){ NWF$(repeatingSection).css({"visibility": "visible"}); }); });

Custom CSS
 
.nf-item {
}
.nf-item-alternating {
    background-color: white;
}

// place the following command below the two commands above (which are already there). It makes sure that the first, properly hidden, row of the repeating section is not displayed at all.
.nf-repeater-row-hidden {
    display: none;
}

These two steps should resolve the issue if your setup is similar to mine.

 

Reply
gaelyvin999
Scholar

Re: Repeating section field area is blank after submitting

Jump to solution
thank you !!!!!!!
0 Kudos
Reply