Steven_gatt
Canvas Initiate

Failed to Send Notification. Object reference not set to an instance of an object

Hi, 

 

I am encountering an issue with Nintex Workflow for the Send Notification action, whereby the action fails with the following error : 

 
Failed to send notification. Object reference not set to an instance of an object.
 
The Send Notification action does not fail if I put the e-mail address directly in the action like so :
Steven_gatt_0-1620373476820.png

 

However if I place the same e-mail address in a variable or read it from an item property and use that variable/item property in the To* field , the error occurs. 

 

Steven_gatt_1-1620373590026.png

 

I am also logging the variable in Log to History action and it is being logged correctly.

 

Any help with regards to either debugging the issue or solving it would be greatly appreciated.

 

Thanks.

0 Kudos
Reply
2 Replies
kunalpatel
Automation Master
Automation Master

Re: Failed to Send Notification. Object reference not set to an instance of an object

@Steven_gatt ….Can you try in other browsers? Also try to delete all the cache, history, form data, etc. for all time and see if that fixes it. Can you also check if there are any space in the variable value, usually when I capture variable values, I use [{WorkflowVariable}]. Instead of email can't you use domain ID?

0 Kudos
Reply
Steven_gatt
Canvas Initiate

Re: Failed to Send Notification. Object reference not set to an instance of an object

@kunalpatel Thanks for your suggestions, I tried them and the issue was still present. I did some further investigation and it seems that the system in question has a custom claims provider deployed as a wsp on the farm and their is an issue when users who are authenticating with the custom claims are involved in workflows that send e-mails. If we find a solution I will post it here for possible future reference.

Reply