cancel
Showing results for 
Search instead for 
Did you mean: 

RPA scripts will not run on minimized RDP session

Issue

RPA will not run scripts properly if ran in an remote desktop session and that session is minimized or disconnected from.

 

Resolution

Microsoft Windows includes an application called Remote Desktop that allows a user to connect to a remote computer. Often times, users will install Foxtrot on a remote computer and access it through Remote Desktop. If the user minimizes the Remote Desktop application, it causes the remote session to switch to a GUI-less mode which does not display windows or controls. When this occurs, Foxtrot is unable to interact with these applications causing the script to stop.

Depending on the software (application) you use to establish your remote connections, you may be able to implement these following settings there. This article explains how you implement it in your Windows Registry Editor. Note: These changes should only be made if you are comfortable with working in and modifying the Windows registry.

To prevent Remote Desktop from switching to a GUI-less mode when minimized, choose one of the following. The following steps must be completed under a Windows profile with administrative privileges on the host computer (the one accessing the machine with the robot, therefore, the user computer):

  1. Close all Remote Desktop sessions
  2. Launch the Registry Editor by typing regedit.exe in Windows Run command
  3. Locate the following registry key:
    a. To change the setting for all user accounts:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client\
  4. Create a new DWORD value in this key named RemoteDesktop_SuppressWhenMinimized
  5. Specify 2 as the value data
  6. If you are using a 64-bit version of Windows, you should also add the RemoteDesktop_SuppressWhenMinimized value to the following keys under Wow6432Node:
    a. To change the setting for all user accounts:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Terminal Server Client\
  7. Reboot the computer for the changes to take effect
 

Additionally, it can be relevant to disable RD clipboard redirection to avoid the user and robot to overlap when copying and pasting things at the same time. To prevent this, complete the following steps on the host/user computer, using a Windows profile with administrative privileges.

  1. Close all Remote Desktop sessions
  2. Launch the Registry Editor by typing regedit.exe in Windows Run command
  3. Locate the following registry key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client\
  4. Create a new DWORD value in this key named DisableClipboardRedirection
  5. Specify 1 as the value data
  6. If you are using a 64-bit version of Windows, you should also add the DisableClipboardRedirection value to the following keys under Wow6432Node:
    a. To change the setting for all user accounts:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Terminal Server Client\
  7. Reboot the computer for the changes to take effect

 

Labels: (2)
Version history
Revision #:
38 of 38
Last update:
3 weeks ago
Updated by:
 
Contributors