No connection could be made because the target machine actively refused it ip_address:5555 error message while trying to open K2 sites.


K2 Workspace/Designer/Management are not working after updating the SSL certificate for K2 site in IIS.


Binding/Hostname configuration is different on every environment, please check with your IT team.


Server Error

No connection could be made because the target machine actively refused it [machine_name_ip_address]:5555

Image 202.png


The 'No Connection...' message can occur when using Subject Alternative Name (SAN) Certificate that has multiple fully qualify names within a single certificate. In this scenario, the SSL certificate for K2 site is defined with multiple domains and IP addresses. When trying to browse K2 sites, it's attempting to reach other server with either '' host name or '' IP address. 


DNS Name=K2dev


DNS Name=K2Dev




1. Navigate to IIS > Sites > K2_site_name > Bindings and view the SSL certificate for HTTPS hostname.


Image 205.png

2. Subject Alternative Name (SAN) has multiple entries/identifiers. 

Image 203.png


3. The DNS record must be updated on the client side, and the certificate must be re-generated with the correct name (i.e. removing the and

4. The certificate needs to re-import back to the K2 server and re-enable the new certificate to use in IIS for K2 site (see step 1 above).

5. Run K2 Setup Manager shortcut from Windows Start Menu > Programs > K2 > Setup and select Configure option.

6. Step through the wizard screens. When you reach the K2 site wizard, make sure to select the correct binding.

Image 206.png

7. Wait for Setup to complete and you can browse to K2 sites.


Related Links

Labels: (2)
Version history
Revision #:
5 of 5
Last update:
‎05-14-2021 01:36 PM
Updated by: