Unable to run the k2 [blackpearl] Server Service

  • 13 September 2007
  • 5 replies

Badge +1


I'm facing a problem with the k2 configuration: from the workspace i receive this message:

Unable to connect to MACHINE_NAME on port 5252
No connection could be made because the target machine actively refused it.

i assumed that the k2 service is not running. the problem is that everytime i try to start it, ... it just stop

So i enabled the logging and run the k2 [blackpearl] server applcation

i end up with this error message:

"9790","2007-09-13 08:54:19","Error","System","2001","ServerStartError","SourceCode.Hosting.Server.Runtime.HostServerEngine.StartHostServer","2001 Error Starting Host Server: An error occurred creating the configuration section handler for sourcecode.smartfunctions.configsections.managerconfigsection: Could not load file or assembly 'SourceCode.SmartFunctions.Configuration, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) (C:WINDOWSMicrosoft.NETFrameworkv2.0.50727Configmachine.config line 14)","system","MACHINE_IP","MACHINE_NAME","9790","3534dd516697477f8d759a4690942bf2",""

i checked the assemblies but they were of version 4.7124.1.0

Is that the problem? How to fix it?


5 replies

Badge +8

Hi FooZ,

It's already been discussed (and solved) here: http://k2underground.com/forums/thread/17940.aspx

(and here http://k2underground.com/forums/thread/18232.aspx)

 It's because of your previous install of the beta.

Badge +1

Thanks Nicolas,

 i noticed that after publishing my post.

i followed the steps mentioned there and the workspace is working fine now but the Visual Studio.Net is not

i received a notification message saying "package load failure"

part of it was that the package 'sourcecode.visualstudio.workflowpackage, sourcecode.visualstudio, version=, ... ' could not loaded.

any suggestions??

Badge +8
When does this error occur? As soon as you run Visual Studio? When you attempt to create a K2 project? Can you see the K2 designer logo on the VS.Net loading screen?
Badge +1
i receive the error once i run the Visual Studio. and when i try to create a k2 project, i either receive the same error or some other error message depending on the type of project i'm attempting to create.
Badge +8
I suppose you've already tried that, but if not, you should maybe run the Blackpearl Configuration Wizard again. It solves many problems related to assembly loading failures.