Code Fix: A “System.IO.IOException: I/O error occurred” error occurred when deploying a package after upgrading to K2 4.7
KB001812
PRODUCT
Issue Description
After upgrading to K2 blackpearl 4.7, an IOException error occurs when deploying a package containing a Workflow with a Hebrew name. An error occurs stating: “System.IO.IOException: I/O error occurred”.
Error
“System.IO.IOException: I/O error occurred”.
Cause
When a package filename uses ibm437 encoding to create the filename, this converts certain Non-English characters to question marks. On deployment when trying to locate the workflow with the Non-English name, the file cannot be found due to the name being replaced with question marks.
Repro Steps
- Create a workflow in K2 Designer for Visual Studio where the workflow name contains a Hebrew name.
- Design and deploy the workflow.
- Package the workflow using the K2 Package and Deployment MMC tool.
- Notice the IOException error on deployment.
Resolution
ibm437 changed to UTF-8 to ensure the filename stays the same as the workflow name.
- Ensure you have K2 4.7 installed.
- Install the K2 4.7 February 2017 Cumulative Update.
- Get the K2 4.7 February 2017 Cumulative Update FP1 from Regional Support.
- Install K2 4.7 February 2017 Cumulative Update FP1 to apply the fix.