Known Issue: Value cannot be null Error Upgrading to K2 Five (5.1)

  • 16 February 2021
  • 0 replies
  • 138 views

Userlevel 5
Badge +20
 

Known Issue: Value cannot be null Error Upgrading to K2 Five (5.1)

KB002384

PRODUCT
K2 Five 5.1
BASED ON
K2 Five 5.1

 

Issue

When upgrading to K2 Five (5.1) the following error is displayed in the K2 installer trace Logs:

 

AuthorizationBase.Execute:Logged Error: Failed: System.ArgumentNullException: Value cannot be null.Parameter name: name

 

 

 

Cause

In the [Category].[System] table, there are rows for custom category systems that have no names. When upgrading to K2 Five (5.1), these unnamed rows cause the AuthorizationBase.Execute: Logged Error: Failed: System.ArgumentNullException: Value cannot be null.Parameter name: name  error to occur.

Before Upgrading

Run this script prior to upgrading to K2 Five (5.1) to ensure this error doesn't occur during upgrade.

SELECT * FROM [Category].[System] WHERE [Name] = N'';

The unnamed rows are returned:

Image

Resolution

To resolve the unnamed rows in your database, run the following script:

UPDATE [Category].[System] SET

       [Name] = N'Unnamed Category System (ID ' + CONVERT(NVARCHAR(MAX), [Id]) + N')'

WHERE [Name] = N'';

 

If you are upgrading from K2 blackpearl 4.7, change [Name] to [SystemName] and [Id] to [SystemId] in the above script.

 

The unnamed rows are updated.

Image

With the unnamed rows fixed you can upgrade to K2 Five (5.1).

 


0 replies

Be the first to reply!

Reply