Code Fix: Reactivating a SharePoint Site collection, causes the linked SmartForms in the K2 smartforms web part to be lost.

  • 16 February 2021
  • 0 replies
  • 5 views

Badge +6
 

Code Fix: Reactivating a SharePoint Site collection, causes the linked SmartForms in the K2 smartforms web part to be lost.

KB001848

PRODUCT
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
If a K2 smartform web part exists on the main SharePoint page, reactivating the K2 App on the Site Collection causes the web part to revert to the Form which requires you to choose which SmartForm the web part should display instead of retaining the SmartForm that was originally chosen.

Cause
When a Site Collection gets reactivated, a force activate takes place that calls for a clean feature in the K2 Database. The clean-up reinserts the referencing key values after cleaning them up for the Site collection and K2 App, but does not reinsert the referencing key value for the web part after removing it.

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP6 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP6 to apply the fix.
  5. Clear the Browser cache.

 


0 replies

Be the first to reply!

Reply