"Not authenticated" errors seen in InstallerTrace logs after update or reconfiguration failed

  • 16 February 2021
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Issue

When trying to apply a FixPack or reconfiguring K2 with Setup Manager, the operation fails, and when inspecting the InstallerTrace logs, one or more of the following errors are found:

 

AuthorizationBase.Execute: Logged Error: Failed: System.InvalidOperationException: Not authenticatedSmartObjectsActionBase.Execute: Logged Error: Failed: SourceCode.Hosting.Exceptions.AuthenticationException: Primary Credentials Not Authenticated. Session Not Authenticated.ControlUtil.InvokeControlUtil: Logged Error: Error from controlutil output: RegisterControlTypes Failed: Not authenticatedDeployPackage.DataRecieved: Error: SourceCode.Hosting.Exceptions.AuthenticationException: Primary Credentials Not Authenticated. Session Not Authenticated.

 

Diagnosis

K2 Setup Manager and the FixPack installer will attempt to create an internal system user to perform the reconfiguration and update. This internal system has the following FQN: K2SQL:System.

 

The 'K2SQL:System' user is a SQLUM user, and it is stored in the [CustomUM].[User] table on the K2 database during the reconfiguration or update. A system password will also get generated for this user. This password is stored in the K2 database in an encrypted format. This user is then used in various operations, such as deploying packages and registering controls.

 

After the reconfiguration or update, the 'K2SQL:System' user and the system password should get removed from the K2 database. This means each time you run a reconfiguration or update, the 'K2SQL:System' user gets created along with a newly generated system password.

 

If for some reason the K2 Setup Manager or the FixPack installer was previously terminated before it finished running, the 'K2SQL:System' user and the password will remain in the K2 database. This in turn may cause issues when the reconfiguration or update tries to perform operations with this user. If K2 cannot authenticate the 'K2SQL:System' user, you will start seeing "Not Authenticated" or "Primary Credentials Not Authenticated" errors thrown in the InstallerTrace logs.

 

Resolution

To fix this, you have to remove the 'K2SQL:System' user that got left behind, and remove the previous system password. As this requires a direct update to your K2 database, please log a support case with Nintex Support, and request for a Support Engineer to assist you.

 

Please provide this KB and your InstallerTrace logs in the support case so that the Support Engineer can determine if the issue you are facing is indeed what is described in this KB.


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