Code Fix: Unable to upload multiple files or images using the Attachment control

  • 16 February 2021
  • 0 replies
  • 46 views

Badge +6
 

Code Fix: Unable to upload multiple files or images using the Attachment control

KB001817

PRODUCT
K2 smartforms 4.7
BASED ON
K2 smartforms 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

Issue Description
Although the functionality is available to select multiple files or images using the File/Image Attachment control, it was not possible to upload multiple files or images.

Cause
The File/Image Attachment control was configured for multiple file selection but did not support multiple file upload.

Repro Steps

  1. From the View Designer, add a File/Image Attachment control.
  2. Save and Finish the View.
  3. Run the View and select multiple files to be uploaded.
  4. Only one file is uploaded.

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Install the K2 4.7 February 2017 Cumulative Update.
  3. Get the K2 4.7 February 2017 Cumulative Update FP2 from Regional Support.
  4. Install the K2 4.7 February 2017 Cumulative Update FP2 to apply the fix.
  5. Clear the Browser cache.
  6. The functionality to select multiple files is now disabled.

 


0 replies

Be the first to reply!

Reply