ys_chang
Novice

.NetFramework Version in Blackpearl 0807 305

.NetFramwork 2.0 SP?


.NetFramwork 3.0 SP?


.NetFramwork 3.5 SP?


Are this is limit ?


tkx


 

0 Kudos
Reply
4 Replies
jan2
Apprentice

Re: .NetFramework Version in Blackpearl 0807 305

Hi,


K2 blackpearl 0807 needs .net Framework 3.0 installed.


Can you be more precise for this request?

0 Kudos
Reply
ys_chang
Novice

Re: .NetFramework Version in Blackpearl 0807 305

I find one exception when using escalation event.


can't load dll, about system.DataTimeOffset.


This is new in Framework 3.5 ( Framework 2.0 SP1).


When install the Framework 3.5 the esception is fix.


so want to know the really Framework version.


in document only say in framework3.0 and not support orcas * vs2008.


tkx

0 Kudos
Reply
johnny
Apprentice

Re: .NetFramework Version in Blackpearl 0807 305

I am pretty sure .NET 3.5 is not needed as I have done quite a number of 0807v350 setups.  I did however see a particular customer environment where they needed to install .NET 2.0 SP1 (together with .NET 3.0).  Otherwise, the K2 Host Server would take a long time to load the SmartFunctions module.
0 Kudos
Reply
wessel
Novice

Re: .NetFramework Version in Blackpearl 0807 305

Hi ys_chang


Are you sure you have installed the "Visual Studio 2005 extensions for .NET Framework 3.0 (WCF & WPF), November 2006 CTP"?


You can validate that you have the appropriate extensions installed by going into Visual Studio and selecting Help > About. You should see the following extensions listed:


-Extensions for Windows WF
-Orcas Technology Preview - .NET Framework 3.0 Development Tools 1.0


You can make sure that youre prerequisites are correct by going to "K2 blackpearl Installation Guide > Prerequisites > Software by Component > Prerequisites for the K2 for Visual Studio component" in your K2 documentation.


Hope this helps,

0 Kudos
Reply