Not applicable

Calling nintex webservice to delegate throws error

I am testing the Ninte web service to delegate a task, I created a task on the workflow tasks list manually and I have the error below.

1. I used SOAP UI for testing the service with this parameters.

<soapenv:Envelope xmlns:soapenv="" xmlns:nin="">






         <nin:taskListName>Tareas de flujo de trabajo</nin:taskListName>




         <nin:comments>Delegada manualmente</nin:comments>





And the response is this, which in English it says that it cant find a a workflow task for this user.

<soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd="">




         <faultstring>Server was unable to process request. ---> No es posible encontrar una tarea de flujo de trabajo de usuario para esta tarea.</faultstring>





this works fine on qa environment but in production it throws this error.

0 Kudos
2 Replies

Re: Calling nintex webservice to delegate throws error

Hi Alejandro,

try to add the domain to your targetUserName ("domain\sp_adminnintex"). Of course make sure that the task ID is valid also on your prod system.

See the Nintex SDK Web Service reference for further information on the input parameters: Nintex Workflow SDK

Let us know if this already solves your issue.



0 Kudos

Re: Calling nintex webservice to delegate throws error

I have the same error when I call delegateTask web service. It returns a 500 error when ran from workflow designer and when it's running from schedule as site workflow it returns the following error:

08/05/2020 19:20 Workflow Comment Failed to invoke web service. Error returned from server: <soap:Fault xmlns:soap=""><faultcode>soap:Server</faultcode><faultstring>Server was unable to process request. ---&gt; Item does not exist. It may have been  
08/05/2020 19:20 Error An error has occurred in TEST to re-assign a task.


Since the delegateAllTasks webservice call works just fine it's either the List Name or Task Id that I don't get right however both are valid to me.

Is the TaskId in the call the same as the Workflow Task List Item ID or something else ?

The nintex task list name is "Workflow Tasks". I tried using the GUI instead but same error.

Below are the details any wrong (I stripped out the user name):

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="" xmlns:m="" xmlns:xsi="">
<soap:Header />
<m:taskListName>Workflow Tasks</m:taskListName>




0 Kudos