AnsweredAssumed Answered

Query XML doesn't work

Question asked by jeroenwetzels on Dec 9, 2015
Latest reply on Dec 28, 2015 by damien.l

I've created a workflow, in which I first "call web service" and after that I tried too "Query XML".

 

The XML which i received form the web services is:

 

<AfasGetConnector>  <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">   <xs:element name="AfasGetConnector">    <xs:complexType>     <xs:choice maxOccurs="unbounded">      <xs:element name="AFAS2SPIB">       <xs:complexType>        <xs:sequence>         <xs:element name="Naam" type="xs:string" minOccurs="0"/>         <xs:element name="Jaar" type="xs:long" minOccurs="0"/>         <xs:element name="Oracle_accountnr." type="xs:string" minOccurs="0"/>        </xs:sequence>       </xs:complexType>      </xs:element>     </xs:choice>    </xs:complexType>   </xs:element>  </xs:schema>  <AFAS2SPIB>   <Naam>Vermeulen, G.C.M.</Naam>   <Jaar>2016</Jaar>   <Oracle_accountnr.>36244</Oracle_accountnr.>  </AFAS2SPIB>  <AFAS2SPIB>   <Naam>Vedder, J.</Naam>   <Jaar>2015</Jaar>   <Oracle_accountnr.>29413</Oracle_accountnr.>  </AFAS2SPIB> </AfasGetConnector>

 

Now i would like to have a collection  of "Oracle_accountnr." Therefore i've configured the "Query XML"-function like this:

Query XML.jpg

If i check the "colOracleNumbers" i got exactly the same result as the  xml I've posted above.

Outcomes